commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <>
Subject Re: [pool] GKOP s/maxIdle/maxIdlePerKey?
Date Sat, 04 Jun 2011 21:28:05 GMT
On 6/4/11 2:08 PM, Mark Thomas wrote:
> On 04/06/2011 22:06, Phil Steitz wrote:
>> On 6/4/11 12:05 PM, Mark Thomas wrote:
>>> On 04/06/2011 18:41, Simone Tripodi wrote:
>>>> It makes a lot of sense and makes clearer fields semantics, +1
>>> +1
>>> Note, there will need to be some refactoring in the Config classes for this.
>> Yes, and it will increase the smell in what I personally see as
>> over-engineered inheritence in the config classes.  Since minIdle,
>> maxIdle are not now used or defined in GKOP, these will be unused
>> and confusing config fields for GKOP.  This and the fact that some
>> defaults are different and the config params have different meanings
>> leads me to suggest that we dispense with BaseObjectPoolConfig and
>> just repeat the common fields for GKOP, GOP configs.  It is
>> essential that we define config params precisely and completely in
>> javadoc and this will be easier if we separate the configs.
> If there is any commonality I would prefer to see it remain in the base
> class (I like to avoid copy and paste coding)

I do too and I agree that some of the bad javadoc in earlier
versions of [pool] was the result of exactly that - trying to
"reuse" via cut and past imprecise property descriptions between GOP
and GKOP.  DBCP was, and to some extent still is, infected by this. 
I will take a crack at pulling out all the stuff that needs
different descriptions between GOP and GKOP and see what remains.

>  but I have no issue
> separating out things that are different.
> Mark
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message