commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <>
Subject Re: [pool] GKOP s/maxIdle/maxIdlePerKey?
Date Sat, 04 Jun 2011 21:08:43 GMT
On 04/06/2011 22:06, Phil Steitz wrote:
> On 6/4/11 12:05 PM, Mark Thomas wrote:
>> On 04/06/2011 18:41, Simone Tripodi wrote:
>>> It makes a lot of sense and makes clearer fields semantics, +1
>> +1
>> Note, there will need to be some refactoring in the Config classes for this.
> Yes, and it will increase the smell in what I personally see as
> over-engineered inheritence in the config classes.  Since minIdle,
> maxIdle are not now used or defined in GKOP, these will be unused
> and confusing config fields for GKOP.  This and the fact that some
> defaults are different and the config params have different meanings
> leads me to suggest that we dispense with BaseObjectPoolConfig and
> just repeat the common fields for GKOP, GOP configs.  It is
> essential that we define config params precisely and completely in
> javadoc and this will be easier if we separate the configs.

If there is any commonality I would prefer to see it remain in the base
class (I like to avoid copy and paste coding) but I have no issue
separating out things that are different.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message