commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <phil.ste...@gmail.com>
Subject Re: [POOL2] Java 1.5 or 1.6?
Date Fri, 06 May 2011 15:06:34 GMT
On 5/6/11 5:13 AM, Jochen Wiedmann wrote:
> On Fri, May 6, 2011 at 1:57 PM, sebb <sebbaz@gmail.com> wrote:
>
>> Not all OSes are supported by Sun/Oracle, and not all JVM vendors
>> update their products as quickly.
>>
>> There may still be OSes that don't support Java 1.6 yet.
> They still have pool 1.
>
>
>> Also, won't requiring 1.6 for Pool force DBCP to use 1.6 also?
> At the point when DBCP chooses to use pool 2 and not pool 1 as a
> dependency. No reason to do that now. Due to the binary
> incompatibility, I'd recommend the contrary.

Right.  An important additional note is that DBCP 2 will require 1.6
in any case.  We discussed earlier and decided to drop JDBC 3
support in DBCP 2 - i.e., there will be only one DBCP 2,x version
and that version will require JDBC 4 so JDK 1.6.

Phil
>
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message