commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <joerg.schai...@gmx.de>
Subject Re: [DBCP] Confusing versioning numbering
Date Wed, 27 Apr 2011 22:01:28 GMT
Gary Gregory wrote:

> IMO:
> 
> DBCP 1.4 for JDBC 4 (JDK 1.6)
> => Bump it to 2.0.
> 
> DBCP 1.3 for JDBC 3 (JDK 1.4-1.5)
> => Stays as is.

As Phil said, it was discussed at release time. The main reason to go with 
this version scheme is, that you can simply exchange the 1.3.x with 1.4.x 
version when you switch your application from Java 5 to Java 6. It's binary 
compatible.

- Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message