commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Yandell <flame...@gmail.com>
Subject Re: [Lang] ClassUtils getShortClassName != Class getSimpleName
Date Mon, 11 Apr 2011 23:19:04 GMT
On Mon, Apr 11, 2011 at 3:43 PM, Gary Gregory <garydgregory@gmail.com> wrote:
> On Mon, Apr 11, 2011 at 4:26 PM, Henri Yandell <flamefew@gmail.com> wrote:
>>
>> +1 to rename getShortClassName to getSimpleName; sitting on top of the
>> JDK getSimpleName and providing null safety and whatever other
>> features are needed (for example array encoding).
>
> You must mean deprecate getShortClassName (to remove in 4.0) and add
> getSimpleName. Right?

Nope. Remove getShortClassName and add getSimpleName. We're not
released yet so we can (and should) still make backwards compat
changes.

Hen

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message