commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Gregory <garydgreg...@gmail.com>
Subject Re: [Lang] ClassUtils getShortClassName != Class getSimpleName
Date Thu, 21 Apr 2011 15:31:29 GMT
On Mon, Apr 11, 2011 at 7:19 PM, Henri Yandell <flamefew@gmail.com> wrote:

> On Mon, Apr 11, 2011 at 3:43 PM, Gary Gregory <garydgregory@gmail.com>
> wrote:
> > On Mon, Apr 11, 2011 at 4:26 PM, Henri Yandell <flamefew@gmail.com>
> wrote:
> >>
> >> +1 to rename getShortClassName to getSimpleName; sitting on top of the
> >> JDK getSimpleName and providing null safety and whatever other
> >> features are needed (for example array encoding).
> >
> > You must mean deprecate getShortClassName (to remove in 4.0) and add
> > getSimpleName. Right?
>
> Nope. Remove getShortClassName and add getSimpleName. We're not
> released yet so we can (and should) still make backwards compat
> changes.
>
> Hen
>

getShortClassName is in 2.6.

Gary


-- 
Thank you,
Gary

http://garygregory.wordpress.com/
http://garygregory.com/
http://people.apache.org/~ggregory/
http://twitter.com/GaryGregory

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message