commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Benedict <pbened...@apache.org>
Subject Re: [lang] Pair vs. [collection] org.apache.commons.collections.keyvalue
Date Tue, 12 Apr 2011 17:36:08 GMT
I think "tuple" is a better package name. In geo-coordinates, I don't think
it's proper to call Longtitude a key and Latitude a value. It's just a tuple
of values. Same thing for 3d dimension space, etc.

On Tue, Apr 12, 2011 at 12:33 PM, Gary Gregory <garydgregory@gmail.com>wrote:

> On Tue, Apr 12, 2011 at 12:16 PM, Stephen Colebourne
> <scolebourne@joda.org>wrote:
>
> > On 12 April 2011 17:10, Matt Benson <gudnabrsam@gmail.com> wrote:
> > > On Tue, Apr 12, 2011 at 10:20 AM, Stephen Colebourne
> > > <scolebourne@joda.org> wrote:
> > >> The [collections] KeyValue class was a mistake. [lang] Pair is a
> > >> better more general concept.
> > >>
> > >> The only thing I'd consider with [lang] Pair now is whether it should
> > >> move to its own package, in case it grows later (primitive versions).
> > >>
> > >
> > > oacl.tuple?
> >
> > +1
>
> Gary
>
>
> > If we create a package, that would be the name I'd choose.
> > Stephen
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> > For additional commands, e-mail: dev-help@commons.apache.org
> >
> >
>
>
> --
> Thank you,
> Gary
>
> http://garygregory.wordpress.com/
> http://garygregory.com/
> http://people.apache.org/~ggregory/
> http://twitter.com/GaryGregory
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message