commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Yandell <flame...@gmail.com>
Subject Re: [Lang] ClassUtils getShortClassName != Class getSimpleName
Date Fri, 22 Apr 2011 06:33:59 GMT
On Thu, Apr 21, 2011 at 12:01 PM, Gary Gregory <garydgregory@gmail.com> wrote:
> On Thu, Apr 21, 2011 at 2:38 PM, Henri Yandell <flamefew@gmail.com> wrote:
>>
>> On Thu, Apr 21, 2011 at 8:31 AM, Gary Gregory <garydgregory@gmail.com>
>> wrote:
>> > On Mon, Apr 11, 2011 at 7:19 PM, Henri Yandell <flamefew@gmail.com>
>> > wrote:
>> >>
>> >> On Mon, Apr 11, 2011 at 3:43 PM, Gary Gregory <garydgregory@gmail.com>
>> >> wrote:
>> >> > On Mon, Apr 11, 2011 at 4:26 PM, Henri Yandell <flamefew@gmail.com>
>> >> > wrote:
>> >> >>
>> >> >> +1 to rename getShortClassName to getSimpleName; sitting on top
of
>> >> >> the
>> >> >> JDK getSimpleName and providing null safety and whatever other
>> >> >> features are needed (for example array encoding).
>> >> >
>> >> > You must mean deprecate getShortClassName (to remove in 4.0) and add
>> >> > getSimpleName. Right?
>> >>
>> >> Nope. Remove getShortClassName and add getSimpleName. We're not
>> >> released yet so we can (and should) still make backwards compat
>> >> changes.
>> >>
>> >> Hen
>> >
>> > getShortClassName is in 2.6.
>>
>> So? It can be removed in 3.0 if it's pointless and replaced by
>> getSimpleName.
>
> Yes, that's true. I thought it would be polite to deprecate the method first
> but I suppose there is no rule that says we have to do it that way.
>
> I was just surprised by methods disappearing in WSS4J 1.6 from 1.5.x without
> deprecation in 1.5.x.
>
> Because major releases can break things, I now understand it is permitted to
> do this kind of change.
>
> We now two new methods:
>
> org.apache.commons.lang3.ClassUtils.getSimpleName(Class<?>)
> org.apache.commons.lang3.ClassUtils.getSimpleName(Object, String)
>
> Which should replace:
>
> getShortClassName(Class<?>)
> getShortClassName(Object, String)
>
> The question is, what do we do about:
>
> org.apache.commons.lang3.ClassUtils.getShortClassName(String)
>
> Changing the impl to call getSimpleName(Class<?>) with the result of
> Class.forName() smells wrong.

Keep it and simply rename to getSimpleName with the intent that it
would match the JVM version?

Hen

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message