commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Bourg <ebo...@apache.org>
Subject Re: [CLI] fixing warnings
Date Thu, 21 Apr 2011 12:24:03 GMT
Le 21/04/2011 14:03, sebb a écrit :

> Depends on the compiler target. If you target 1.5 or later, then
> @Deprecated and @Override should be used.

That's your choice, there is no Java police that make these annotations 
mandatory. The lack of comment associated with the @Deprecated 
annotation makes it inferior to the javadoc tag.


> That may break binary compatibility.

True, but not for a private field if I'm not mistaken.

Emmanuel Bourg


Mime
View raw message