commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Gregory <garydgreg...@gmail.com>
Subject Re: [parent] wagon protocols & mvn3
Date Mon, 04 Apr 2011 11:54:22 GMT
I have https URLs in my settings.xml. Maybe that's it.

Gary

On Apr 4, 2011, at 1:52, Simone Tripodi <simonetripodi@apache.org> wrote:

> Hi Gary,
> I honestly don't know why, I'm not in the position to reply, but while
> trying to release the discovery-0.5-RC1 using mvn3 I got the error
> below; after a little investigation I found the wiki page I reported
> in my previous message that reports such "issue"...
> Simo
>
>   [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-deploy-plugin:2.5:deploy
> (default-deploy) on project commons-discovery: Failed to deploy
> artifacts/metadata: No connector available to access repository
> apache.snapshots
> (scp://people.apache.org/www/people.apache.org/builds/commons/discovery/0.5/RC1/staged)
> of type default using the available factories
> WagonRepositoryConnectorFactory
>
> http://people.apache.org/~simonetripodi/
> http://www.99soft.org/
>
>
>
> On Sun, Apr 3, 2011 at 11:20 PM, Gary Gregory <garydgregory@gmail.com> wrote:
>> Why did I not run into this when releasing codec? I used M3.
>>
>> Gary
>>
>> On Apr 3, 2011, at 17:04, Simone Tripodi <simonetripodi@apache.org> wrote:
>>
>>> Hi Rahul!
>>> done, but I meant that in mvn3 the scp protocol doesn't come out of
>>> the box, we need to plug the wagon-ssh extension.
>>> For releasing the discovery, I switched to mvn2, but for future mvn3
>>> use I'd suggest to add it in the maven-3 profile in the parent pom.
>>> Have a nice day, all the best!
>>> Simo
>>>
>>> http://people.apache.org/~simonetripodi/
>>> http://www.99soft.org/
>>>
>>>
>>>
>>> On Sun, Apr 3, 2011 at 10:52 PM, Rahul Akolkar <rahul.akolkar@gmail.com>
wrote:
>>>> On Sun, Apr 3, 2011 at 3:36 PM, Simone Tripodi <simonetripodi@apache.org>
wrote:
>>>>> Hi all guys,
>>>>> due to unsupported 'scp' protocol by default by mvn3[1], I'd suggest
>>>>> to add, in the 'maven-3' profile in the commons-parent, the wagon-ssh
>>>>> extension.
>>>> <snip/>
>>>>
>>>> For now, you could try tweaking the "commons.deployment.protocol"
>>>> property (see very bottom of parent pom).
>>>>
>>>> -Rahul
>>>>
>>>>
>>>>> If there isn't any objection, I can take care of it, just let me know.
>>>>> In the meanwhile, I'd add the wagon-ssh in the [discovery] pom, is it
>>>>> fine for you or he have to release the parent first?
>>>>> Thanks in advance,
>>>>> Simo
>>>>>
>>>>> [1] https://cwiki.apache.org/MAVEN/maven-3x-compatibility-notes.html#Maven3.xCompatibilityNotes-TransportProtocols%2528Wagons%2529
>>>>>
>>>>> http://people.apache.org/~simonetripodi/
>>>>> http://www.99soft.org/
>>>>>
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>
>>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>> For additional commands, e-mail: dev-help@commons.apache.org
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message