commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralph Goers <ralph.go...@dslextreme.com>
Subject Re: [SITE] Problems using Commons Skin3/Parent 19 with VFS
Date Wed, 09 Mar 2011 16:33:05 GMT
All I did was "mvn site:stage -DstagingDirectory="/Users/rgoers/vfssite".

Without doing mvn site:stage the site you generated can't possibly be correct. You won't be
able to navigate to any of the subprojects.

I'll do a mvn clean and try it again, but I can't do it until tonight. (at least 12 hrs from
now) as I have to go to work.

Ralph

On Mar 9, 2011, at 8:27 AM, sebb wrote:

> @Ralph (mainly)
> 
> I've taken a look at the site you zipped up and sent to me privately.
> 
> It does not have any of the changes, so it looks like the updated
> parent and skin were somehow not being picked up.
> 
> I updated my copy of VFS to the current trunk, and replaced the POM
> with the one you sent me.
> 
> mvn site
> 
> fails for me, because of problems compiling some Sandbox classes, so I
> commented that out of the pom (BTW, perhaps Sandbox should be subject
> to an optional profile).
> 
> mvn site
> 
> now work OK for me, and uses the new parent/site.xml.
> 
> I then tried deleting Commons Skin 3 and Parent 19 from my local
> workspace, and again all works fine.
> 
> What commands were you using to build the site?
> 
> I used:
> 
> mvn site -DskipTests -Dmaven.javadoc.skip -Dmaven.clover.skip
> -DgenerateReports=false
> 
> The skip options are just to speed up the build
> 
> Please try that after "mvn clean".
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message