commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Gregory <garydgreg...@gmail.com>
Subject Re: [parent] maven 3 vs. 2 trick not inherited from commons-parent
Date Fri, 11 Mar 2011 03:41:00 GMT
On Thu, Mar 10, 2011 at 10:27 PM, Jörg Schaible <joerg.schaible@gmx.de>wrote:

> Hi Gary,
>
> Gary Gregory wrote:
>
> > In [paren] v18, we have a nice trick to use maven-site-plugin 2.x with
> > Maven 2.x and maven-site-plugin 3.x with Maven 3.x .
> >
> > See
> >
> http://maven.apache.org/plugins/maven-site-plugin-3.0-beta-3/maven-3.html
> >
> > If you want to look at the parent POM, look for:
> >
> >     <profile>
> >       <id>maven-3</id>
> >
> > But, this does not work.
>
> What do you men with "this does not work"? It does.
>

If I take out the profiles element from the [codec] POM (from SVN) and run
"mvn clean site" with Maven 3, (almost) nothing happens. M3 says the build
was OK but it does not do anything.

Gary


>
> > When I have the same bit of XML in [codec]'s POM for example, it works.
> >
> > Any ideas what needs to be done for this to work without adding the XML
> to
> > every project?
> >
> > For [codec], it just works, you invoke m2 or m3 without additional
> > arguments.
>
> - Jörg
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>


-- 
Thank you,
Gary

http://garygregory.wordpress.com/
http://garygregory.com/
http://people.apache.org/~ggregory/
http://twitter.com/GaryGregory

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message