commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: svn commit: r1086810 - /commons/proper/pool/branches/POOL_1_X/pom.xml
Date Thu, 31 Mar 2011 01:46:18 GMT
On 31 March 2011 02:00, Niall Pemberton <niall.pemberton@gmail.com> wrote:
> On Wed, Mar 30, 2011 at 6:30 AM, Phil Steitz <phil.steitz@gmail.com> wrote:
>> On 3/29/11 6:30 PM, sebb wrote:
>>> On 30 March 2011 01:13,  <psteitz@apache.org> wrote:
>>>> Author: psteitz
>>>> Date: Wed Mar 30 00:13:51 2011
>>>> New Revision: 1086810
>>>>
>>>> URL: http://svn.apache.org/viewvc?rev=1086810&view=rev
>>>> Log:
>>>> Upgraded parent pom, downgraded assembly plugin to working version.
>>> What is the exact problem? I'm happy to raise a bug and create test
>>> cases etc., but I don't know what the issue is.
>>
>> Per Niall's comments during the vote on parent 19 or 20,  with the
>> later version of the assembly plugin in the current Commons parent
>> mvn -Prc -DcreateChecksum=true install
>> does not create, sign and install the tars/zips to the local repo.
>
> I found that doing "mvn -Prc install" didn't work - but adding clean
> (i.e.  "mvn -Prc clean install") caused it to work just fine.

Odd, why should clean work?

I found that

mvn -Prc package install

works, but that makes a bit more sense as the package presumably needs
to attach the goal.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message