commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject [attributes] Gump failure after qdox update
Date Fri, 11 Feb 2011 08:55:53 GMT
On 2011-02-11, Gump wrote:

>     [javac] /srv/gump/public/workspace/apache-commons/attributes/compiler/src/java/org/apache/commons/attributes/compiler/AttributeCompiler.java:245:
incompatible types
>     [javac] found   : com.thoughtworks.qdox.model.JavaPackage
>     [javac] required: java.lang.String
>     [javac]         packageName = javaClass.getPackage ();
>     [javac]                                            ^

This started when I upgraded Gump's version of qdox from 1.6 to 1.12
('cause FOP needed the newer version).

IIUC there hasn't been any change in attributes for two years so I'm not
sure what to do with it.  Try to adapt attributes to a newer qdox?
Provide the old qdox to attributes in Gump so it can build even though
no other project in Gump needs it?  Remove attributes from Gump?

Any ideas?

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message