commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Giannakopoulos <miccagi...@gmail.com>
Subject Re: [Math] Refactoring of package "analysis.integration" (MATH-501)
Date Fri, 28 Jan 2011 23:20:32 GMT
Also, the file 'ResizableDoubleArray.java' in the package
'org.apache.commons.math.util' contains the following code:

>if (contraction < expansion) {
>            throw MathRuntimeException.createIllegalArgumentException(
>
LocalizedFormats.CONTRACTION_CRITERIA_SMALLER_THAN_EXPANSION_FACTOR,
>                    contraction, expansion);
>}

This case is similar with the second one that i mention in my previous mail.
So i believe that we need a new class that is going to implement the fact
that lower has exceeded the upper... I would like to hear from you about
this issue. Thanks a lot!

Best regards,
Michael Giannakopoulos

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message