commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <joerg.schai...@gmx.de>
Subject Re: [VOTE] Release Commons VFS 2.0
Date Fri, 05 Nov 2010 18:42:02 GMT
sebb wrote:

> On 5 November 2010 17:36, Jörg Schaible <joerg.schaible@gmx.de> wrote:
>> sebb wrote:
>>
>>> On 5 November 2010 17:11, Jörg Schaible <joerg.schaible@gmx.de> wrote:
>>>> Gary Gregory wrote:
>>>>
>>>>> One thing that drives me nuts is that most project do not list the JRE
>>>>> requirements on the front page of the project. It's not even in the
>>>>> project dependencies either.
>>>>>
>>>>> So we should at least update the docs IMO for Java 5.
>>>>
>>>> +1
>>>>
>>>> Not a blocker though.
>>>>
>>>> However, it seems that the news section should have been really updated
>>>> as proposed: Minimum Java 1.4 (or 5 - depends on what we decide).
>>>
>>> It's not possible currently to compile the core code using Java 1.4.
>>>
>>> Since we ship source, I think this is a blocker.
>>
>> Not if we increase the (documented) minimum Java version to 5 ;-)
>> Then Ralph can release if the vote passes.
> 
> But that requires a new RC to fix the version of Java which is in
> pom.xml and of course in the Manifests.

It does not really harm that the target JDK has been 1.4.

> Possibly elsewhere too in the source files.
> 
> Either way, I think we need a new RC.

As long as minimum JDK is documented on the VFS home page, I'm fine with it 
for Java 5.

- Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message