commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <joerg.schai...@gmx.de>
Subject Re: [VOTE] Release Commons VFS 2.0
Date Fri, 05 Nov 2010 16:30:47 GMT
Ralph Goers wrote:

> 
> On Nov 5, 2010, at 8:51 AM, Jörg Schaible wrote:
> 
>> Hi James,
>> 
>> James Carman wrote:
>> 
>>> On Fri, Nov 5, 2010 at 11:30 AM, Ralph Goers
>>> <ralph.goers@dslextreme.com> wrote:
>>>> 
>>>> Do you really consider this to be a -1?  I consider this to be a
>>>> documentation issue.  User's can pick and choose which providers they
>>>> want and simply need to be aware that Net 2.0 requires 1.5.
>>>> 
>>> 
>>> The providers are auto-registered based on what's on the classpath.
>>> So, if they added net 2.0 to their classpath, that provider would be
>>> registered.  It may not be completely obvious that net 2.0 requires
>>> 1.5+.
>> 
>> This is not the point. If they add net 2.0 to the classpath they are
>> using Java 5 probably anyway. The interesting quesiton is, what happens
>> if net 1.4 is on the classpath? I'd guess the provider is also
>> auto-registered, but will crash at some point ...
>> 
>>> I agree this is probably just a documentation issue.  Don't
>>> know if it should be a blocker.
>> 
>> If the application will crash, just because net 1.4 is on the classpath,
>> it is a blocker. If an application can run as logn as it does not use the
>> stuff requiring net 2.0, it's unfortunate, but documentation is enough.
> 
> I would have expected causing an application to crash because 1.4 is on
> the classpath would have been a blocker to the net 2.0 release, not a
> blocker for something using commons net.

If VFS uses functionality only available in net-2.0, it's not net-2.0s 
fault.

> Were incompatible API changes
> made or just the bump in the minimum JVM?

http://article.gmane.org/gmane.comp.jakarta.commons.devel/88018

It seems that some classes had been moved. Rereading the discussion in the 
thread it was supposed to be a "different code line". Why the recommendation 
to use a different package name was not followed, I could not find in the 
archives for now, but we're bitten now by this decision from 4 years ago ...

As alternative: Can't we simply raise the minimum JDK level for VFS to 1.5 
also?

- Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message