commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Carman <ja...@carmanconsulting.com>
Subject Re: [VOTE] Accept the package name/artifactId guideline as a "rule"...
Date Wed, 24 Nov 2010 21:38:22 GMT
That's already part of the binary compatibility rule
On Nov 24, 2010 4:31 PM, "Ralph Goers" <ralph.goers@dslextreme.com> wrote:
>
> On Nov 24, 2010, at 11:43 AM, James Carman wrote:
>
>> On Wed, Nov 24, 2010 at 12:00 PM, Ralph Goers
>> <ralph.goers@dslextreme.com> wrote:
>>>
>>> I disagree. The "rule" should be that a new package and artifactId is
required when compatibility is broken, not when a version change occurs.
Exceptions should be based on that policy, not on a version change occurs.
>>>
>>
>> Ok, so how about we change the rule? We could say "if the binary
>> compatibility is broken, then the package/artifactId must change."
>> Again, this rule can be broken if a component feels they need to do so
>> and they provide a very good reason. :)
>
> I would agree with this. However, I would suggest that if the package and
artifactId change the version MUST change.
>
> Ralph
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message