commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henning Schmiedehausen <henn...@schmiedehausen.org>
Subject Re: [VFS] Update dependencies?
Date Tue, 09 Nov 2010 17:47:05 GMT
This opens the philosophical can of worms of whether the dependencies
in the POM should be the 'least version required to run this' or 'the
latest and greatest'.

personally, I prefer the former. If someone integrating vfs uses
commons-collections-3.2.1 in their project, they will override the
transitive dependency of commons-vfs. But if someone integrating
commons-vfs needs to use commons-collections-3.1 for whatever reason,
then dragging in a sudden dependency change will screw them over.

So I am -1 on this change. Please don't do it.

-h



On Mon, Nov 8, 2010 at 04:13, sebb <sebbaz@gmail.com> wrote:
> The following dependencies could potentially be updated:
>
> ant:ant ............................................... 1.6.2 -> 1.6.5
> commons-httpclient:commons-httpclient ..................... 3.0 -> 3.1
> commons-collections:commons-collections ................. 3.1 -> 3.2.1
> javax.mail:mail ......................................... 1.4 -> 1.4.1
> org.apache.jackrabbit:jackrabbit-webdav ............... 1.5.2 -> 2.1.2
> xml-apis:xml-apis .................................... 1.0.b2 -> 2.0.2
>
> I think we should update most, if not all of them.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message