commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralph Goers <ralph.go...@dslextreme.com>
Subject Re: [VOTE] Release Commons VFS 2.0
Date Fri, 05 Nov 2010 16:28:57 GMT

On Nov 5, 2010, at 9:10 AM, sebb wrote:

> On 5 November 2010 15:30, Ralph Goers <ralph.goers@dslextreme.com> wrote:
>> 
>> On Nov 5, 2010, at 2:49 AM, sebb wrote:
>> 
>>> On 5 November 2010 03:05, Ralph Goers <ralph.goers@dslextreme.com> wrote:
>>>> This is a vote to release Apache Commons VFS 2.0.
>>>> 
>>>> [ ] +1 release it
>>>> [ ] +0 go ahead I don't care
>>>> [X] -1 no, do not release it because...
>>> 
>>> The code has a dependency on Commons NET 2.0, which requires Java 1.5+
>>> However VFS targets Java 1.4+
>> 
>> Do you really consider this to be a -1?  I consider this to be a documentation issue.
 User's can pick and choose which providers they want and simply need to be aware that Net
2.0 requires 1.5.
> 
> If NET 2.0 is truly optional, then it is not a blocker so long as it
> is clearly documented.
> 
> I assume that NET 2.0 was added in order to support FTPS?

I have no idea. You did the update from 1.4.1 to 2.0 in 999496 on 09/21/10. The support for
FTPS was added in 993534 by jcarman on 09/0710.

> 
> If so, what about someone using Java 1.4 - can they update to VFS 2.0,
> but keep the FTP support from NET 1.4?
> Or will they lose FTP support entirely?

Both FTP and FTPS look for the presence of org.apache.commons.net.ftp.FTPFile. I would assume
that in a Java 1.4 system Net 2.0 would cause a wrong version error when the jar is loaded.
VFS is looking for a ClassNotFoundException to determine whether the dependency is present.
I don't recall what exception/error is thrown when the version is wrong.

Ralph




---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message