commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Gregory <GGreg...@seagullsoftware.com>
Subject RE: VFS release
Date Mon, 29 Nov 2010 19:26:34 GMT
Hi All:

Is Maven 3 fully supported to build VFS?

I was able to run 'mvn test' successfully but I got:

>mvn test
[INFO] Scanning for projects...
[WARNING]
[WARNING] Some problems were encountered while building the effective model for org.apache.commons:commons-vfs2:jar:2.0-SNAPSHOT
[WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-idea-plugin is
missing. @ org.apache.commons:commons-parent:17, line 317, column 15
[WARNING] 'repositories.repository.layout' for apache.m1 uses the unsupported value 'legacy',
artifact resolution might fail. @ org.apache.commons:commons-vfs2-project:2.0-SNA
PSHOT, C:\Users\ggregory\b\svn\apache.org\commons\vfs\trunk\pom.xml, line 384, column 15
[WARNING]
[WARNING] Some problems were encountered while building the effective model for org.apache.commons:commons-vfs2-examples:jar:2.0-SNAPSHOT
[WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-idea-plugin is
missing. @ org.apache.commons:commons-parent:17, line 317, column 15
[WARNING] 'repositories.repository.layout' for apache.m1 uses the unsupported value 'legacy',
artifact resolution might fail. @ org.apache.commons:commons-vfs2-project:2.0-SNA
PSHOT, C:\Users\ggregory\b\svn\apache.org\commons\vfs\trunk\pom.xml, line 384, column 15
[WARNING]
[WARNING] Some problems were encountered while building the effective model for org.apache.commons:commons-vfs2-sandbox:jar:2.0-SNAPSHOT
[WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-idea-plugin is
missing. @ org.apache.commons:commons-parent:17, line 317, column 15
[WARNING] 'repositories.repository.layout' for apache.m1 uses the unsupported value 'legacy',
artifact resolution might fail. @ org.apache.commons:commons-vfs2-project:2.0-SNA
PSHOT, C:\Users\ggregory\b\svn\apache.org\commons\vfs\trunk\pom.xml, line 384, column 15
[WARNING]
[WARNING] Some problems were encountered while building the effective model for org.apache.commons:commons-vfs2-distribution:pom:2.0-SNAPSHOT
[WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-idea-plugin is
missing. @ org.apache.commons:commons-parent:17, line 317, column 15
[WARNING] 'repositories.repository.layout' for apache.m1 uses the unsupported value 'legacy',
artifact resolution might fail. @ org.apache.commons:commons-vfs2-project:2.0-SNA
PSHOT, C:\Users\ggregory\b\svn\apache.org\commons\vfs\trunk\pom.xml, line 384, column 15
[WARNING]
[WARNING] Some problems were encountered while building the effective model for org.apache.commons:commons-vfs2-project:pom:2.0-SNAPSHOT
[WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-idea-plugin is
missing. @ org.apache.commons:commons-parent:17, line 317, column 15
[WARNING] 'repositories.repository.layout' for apache.m1 uses the unsupported value 'legacy',
artifact resolution might fail. @ line 384, column 15
[WARNING]
[WARNING] It is highly recommended to fix these problems because they threaten the stability
of your build.
[WARNING]
[WARNING] For this reason, future Maven versions might no longer support building such malformed
projects.
[WARNING]

When I ran 'mvn eclipse:eclipse', it failed:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-eclipse-plugin:2.8:eclipse (default-cli)
on project commons-vfs2: Execution default-cli of goal org.apache.maven.
plugins:maven-eclipse-plugin:2.8:eclipse failed: String index out of range: -5 -> [Help
1]

I want to set up VFS for Eclipse but I do not want to create a .classpath by hand!

Gary 

> -----Original Message-----
> From: Ralph Goers [mailto:ralph.goers@dslextreme.com]
> Sent: Saturday, November 27, 2010 17:51
> To: Commons Developers List
> Subject: VFS release
> 
> I've gone through Jira and tried to make fixes where it looked like they would
> require changes that could impact binary compatibility.
> 
> There are many bugs related to the FTP variants and after taking several
> passes I've decided to hold off for the time being. Most of the code either
> isn't thread safe or implements concurrency in a manner that is difficult for
> me to understand what it is trying to do. FtpFileObject synchronizes on the
> file system which creates a huge bottleneck and without understanding how
> commons net works it isn't clear to me why this is being done the way it is.
> It almost feels like someone just tried to make it thread safe by brute force.
> OTOH, SftpFileObject doesn't synchronize on anything which looks problematic
> to me. But I have no familiarity with jsch so I suppose I could not be
> understanding something.
> 
> However, I don't believe addressing these issues will impact binary
> compatibility so at this point I think I'm ready to try again to release 2.0.
> 
> WDYT?
> 
> Ralph
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message