commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Carman <ja...@carmanconsulting.com>
Subject Re: [IO] 2.0 RC2 available for review
Date Wed, 06 Oct 2010 15:20:26 GMT
On Wed, Oct 6, 2010 at 11:00 AM, Niall Pemberton
<niall.pemberton@gmail.com> wrote:
>
> There are four people who think 2.0 (Stephen and myself in this thread
> and Sebb and Dennis in the previous thread back in March[1]) that
> think it should be 2.0. So far there are five who think 1.5 (Jörg,
> James, Michael, Paul & Matt). So people disagree. Its OK to have a
> massive debate on this, but I would much rather spend my time on
> something less trivial than version number ideology.
>

The problem is that you're causing some inconsistency.  Bumping major
version numbers without changing package name/artifactId doesn't go
along with what Apache Commons has come up with as a "best practice"
or sorts.  Jumping to 2.0 also carries with it an assumption of binary
incompatibility for most users.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message