commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Ring <...@jdns.org>
Subject Re: [Math] "Order" enum in "MathUtils"
Date Sun, 01 Aug 2010 22:05:34 GMT
FYI,

For a more powerful and useful definition of Ordering, see
http://google-collections.googlecode.com/svn/trunk/javadoc/index.html?com/google/common/collect/Ordering.html.

On Sun, Aug 1, 2010 at 2:58 PM, Gilles Sadowski
<gilles@harfang.homelinux.org> wrote:
> Hi.
>
> So, do you prefer:
> ---
> public enum Order {
>    INCREASING,
>    DECREASING
> }
> ---
> or
> ---
> public enum OrderDirection {
>    INCREASING,
>    DECREASING
> }
> ---
> ?
>
> But are you sure that there won't be anything useful that would justify
> having an enum "Direction" inside an enclosing "Order" (as it is now)?
>
>
> Gilles
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message