commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <phil.ste...@gmail.com>
Subject Re: [VOTE] Release pool 1.5.5 based on RC1
Date Tue, 31 Aug 2010 14:20:26 GMT
Phil Steitz wrote:
> sebb wrote:
>> On 30 August 2010 04:18, Phil Steitz <phil.steitz@gmail.com> wrote:
>>> The distribution zips/tars are here:
>>> http://people.apache.org/~psteitz/pool-1.5.5-RC1/
>>>
>>> Maven artifacts are here:
>>> http://people.apache.org/~psteitz/pool-1.5.5-RC1/maven/
>>>
>>> Site:
>>> http://people.apache.org/~psteitz/pool-1.5.5-RC1/docs/
>>>
>>> Release notes:
>>> http://people.apache.org/~psteitz/pool-1.5.5-RC1/RELEASE-NOTES.txt
>>>
>> I assume the SVN tag is here:
>>
>> http://svn.apache.org/repos/asf/commons/proper/pool/tags/POOL_1_5_5_RC1/
>>
> Yes, sorry.
>> ===
>>
>> There was a missing eol-style, which I have fixed in trunk.
>>
> Thanks!
> 
>> Some minor issues.
>>
>> The MANIFEST.MF files in the Maven artifacts contain the line:
>>      Implementation-Vendor-Id: commons-pool
>> which looks wrong. This ought to be fixed for the next iteration.
>>
> Yes, this needs to be fixed.

Two questions on this:

0) What should it be?  (seems to be org.apache for other components)
1) Maven seems to be getting this from the groupId.  Will it cause
any tools to barf if we change it?

Thanks!

Phil
> 
>> The <scm> entries in th POM point to trunk, rather than the tag.
>> This is presumably because the release plugin was not used.
>>
> Yes, and it is correct, IMO.
> 
>> NOTICE says "Copyright 1999-2010" whereas POM says
>> "<inceptionYear>2001</inceptionYear>"
>> If there is a good reason for the discrepancy it would be helpful to
>> note this in the POM.
>>
> I will look into this.  Could be the code originated in Tomcat, but
> the commons component was born a year later. Assuming this is
> correct, I am not sure where to note this.  Comment in the pom?
> 
>> Compiles and builds OK for me using Java 1.3/1.4/1.5/1.6 on Windows.
>>
> Thanks!
> 
>> Issues with site docs:
>>
>> There is no link for the 1.5.5 Javadoc in the menu. Could perhaps drop
>> 1.5.4 in favour of 1.5.5
>>
> I will do this post-release.
> 
>> downloads.html says:
>> "Versions 1.3-1.5.2 depend at runtime only on a Java 1.3 or better JVM. "
> 
> Good catch.  I will fix this as well post-release.
>>> Votes, please.  This vote will close in 72 hours (2 Sept, 03:30 GMT).
>>>
>>> Thanks in advance.
>>>
>>> Phil
>>>
>>> ------------------------------------------------
>>>
>>> [ ] +1 Proceed with release
>>> [ ] +0 OK, but...
>>> [ ] -0 Would really like to see...
>>> [ ] -1 I am not in favor of this release, because...
>>>
>>> ------------------------------------------------
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>
>>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>> For additional commands, e-mail: dev-help@commons.apache.org
>>
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message