commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luc Maisonobe <Luc.Maison...@free.fr>
Subject Re: [Math] "Order" enum in "MathUtils"
Date Sun, 01 Aug 2010 22:07:13 GMT
Le 01/08/2010 23:58, Gilles Sadowski a écrit :
> Hi.
> 
> So, do you prefer:
> ---
> public enum Order {
>     INCREASING,
>     DECREASING
> }
> ---
> or
> ---
> public enum OrderDirection {
>     INCREASING,
>     DECREASING
> }
> ---
> ?
> 
> But are you sure that there won't be anything useful that would justify
> having an enum "Direction" inside an enclosing "Order" (as it is now)?

I would prefer the second one as it is more focused. If we need another
kind of ordering notion we could add it with a parallel naming scheme.

Luc

> 
> 
> Gilles
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message