commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gilles Sadowski <gil...@harfang.homelinux.org>
Subject [Math] "Order" enum in "MathUtils"
Date Sun, 01 Aug 2010 21:58:23 GMT
Hi.

So, do you prefer:
---
public enum Order {
    INCREASING,
    DECREASING
}
---
or
---
public enum OrderDirection {
    INCREASING,
    DECREASING
}
---
?

But are you sure that there won't be anything useful that would justify
having an enum "Direction" inside an enclosing "Order" (as it is now)?


Gilles

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message