commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gilles Sadowski <gil...@harfang.homelinux.org>
Subject Re: [Math] Backward compatibility
Date Tue, 29 Jun 2010 23:46:58 GMT

> Is it part of a public API that went out in a release already? [...]
> 
> > Is it OK to perform non backward-compatible changes in code that wasn't
> > offcially released yet (i.e. in code tagged with the "@since 2.2" javadoc
> > comment)?

Not in an official release since 2.2 isn't out yet.

> What
> method do you have in mind?

A candidate would be the constructor of
"TricubicSplineInterpolatingFunction" (in package "analysis.interpolation")
that currently throws a checked "DimensionMismatchException" but should
throw an unchecked "DimensionMismatchException" (from the new "exception"
package).


Gilles

P.S. I'd like to perform similar changes (precondition violation generates
     an unchecked exception) in the whole source code but for everything
     released in 2.1 and before, that'll have to wait for the developement
     of version 3.0. :-{

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message