commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <phil.ste...@gmail.com>
Subject Re: [SANDBOX] Need Help Building A Sandbox Site
Date Tue, 06 Apr 2010 11:02:51 GMT
Adrian Crum wrote:
> --- On Sun, 3/28/10, Phil Steitz <phil.steitz@gmail.com> wrote:
>> Adrian Crum wrote:
>>> --- On Sun, 3/28/10, Luc Maisonobe <Luc.Maisonobe@free.fr>
>> wrote:
>>>> Adrian Crum a écrit :
>>>>> --- On Sat, 3/27/10, Phil Steitz <phil.steitz@gmail.com>
>>>> wrote:
>>>>>> Adrian Crum wrote:
>>>>>>> --- On Sat, 3/27/10, Rahul Akolkar
>> <rahul.akolkar@gmail.com>
>>>>>> wrote:
>>>>>>>> Adrian Crum <adrian.crum@yahoo.com>
>>>>>>>> wrote:
>>>>>>>>> I noticed all of the sandbox
>>>> sub-project
>>>>>> links
>>>>>>>> generate a 404 error. I tried to
>> update
>>>> the
>>>>>> sandbox convert
>>>>>>>> site by following the instructions
>> here:
>>>>>>>>> http://commons.apache.org/building.html
>>>>>>>>>
>>>>>>>>> It appeared the mvn site
>> command
>>>> downloaded
>>>>>> poms and
>>>>>>>> jars from the entire Commons
>> project, then
>>>> ran a
>>>>>> build on
>>>>>>>> convert. I'm not sure what I'm
>> supposed to
>>>> do now.
>>>>>> Any
>>>>>>>> guidance would be greatly
>> appreciated!
>>>>>>>> <snip/>
>>>>>>>>
>>>>>>>> Usually just a deploy (assuming
>> mvn site
>>>>>> succeeded, the
>>>>>>>> following in
>>>>>>>> the WC of convert):
>>>>>>>>
>>>>>>>>      mvn
>> site:deploy
>>>>>>>> You may get 404s for other
>> components
>>>> locally, but
>>>>>> should
>>>>>>>> be ok on the
>>>>>>>> webserver assuming the component
>> (pom
>>>> etc.) is set
>>>>>> up
>>>>>>>> correctly.
>>>>>>> Thanks Rahul! the mvn site:deploy
>> command
>>>> asked me for
>>>>>> a password. I tried my svn password, but
>> that
>>>> didn't work.
>>>>>> Any other ideas?
>>>>>> Try putting the following into your maven
>>>> settings.xml
>>>>>> (with your
>>>>>> availId in place of mine):
>>>>>>
>>>>>> <settings>
>>>>>> <servers>
>>>>>>     ...
>>>>>>     <server>
>>>>>>   
>>>>    
>> <id>people.apache.org</id>
>>>>>>   
>>>>    
>> <username>psteitz</username>
>>>>>>      
>>>>>>
>> <filePermissions>664</filePermissions>
>>>>>>      
>>>>>>
>> <directoryPermissions>775</directoryPermissions>
>>>>>>     </server>
>>>>>> </servers>
>>>>>> </settings>
>>>>>>
>>>>>> Then respond to the pwd challenge with
>> your shell
>>>> account
>>>>>> pwd (the
>>>>>> push to people.apache.org is using scp, so
>> you
>>>> are
>>>>>> authenticating to
>>>>>> the box, not svn).
>>>>> Drat. That didn't work either. The script got
>> stuck in
>>>> a loop that repeatedly asked me for my password.
>> Previously,
>>>> it just failed to log in and then exited.
>>>> I think it requires the password a few times (say
>> two or
>>>> three) but
>>>> really proceeds. Is it stuck more than three times
>> in the
>>>> loop ?
>>> I just tried it again. It asked for my password six
>> times, then failed with an auth error.
>>>
>> What was the auth error and what version of maven are you
>> using?
>> Sorry I forgot about the ssh agent compat issue with
>> earlier
>> versions of m2. I had to upgrade to 2.2.1 to get ssh
>> deploys to work.
> 
> Below...

Looks like what I used to get with 2.0.x versions of Maven.  What
version are you running?  IIRC, this problem is caused by ssh
library incompatibility between what is now running on minotaur and
the version of jsch that is being dragged along by maven.  If you
have not done so, try upgrading to maven 2.2.1.

Phil
> 
> 
> scp://people.apache.org/www/commons.apache.org/sandbox/commons-convert - Session
> : Connection refused
> scp://people.apache.org/www/commons.apache.org/sandbox/commons-convert - Session
> : Disconnecting
> scp://people.apache.org/www/commons.apache.org/sandbox/commons-convert - Session
> : Disconnected
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Error uploading site
> 
> Embedded error: Cannot connect. Reason: Auth fail
> [INFO] ------------------------------------------------------------------------
> [INFO] Trace
> org.apache.maven.lifecycle.LifecycleExecutionException: Error uploading site
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(Defa
> ultLifecycleExecutor.java:719)
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandalone
> Goal(DefaultLifecycleExecutor.java:569)
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(Defau
> ltLifecycleExecutor.java:539)
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHan
> dleFailures(DefaultLifecycleExecutor.java:387)
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegmen
> ts(DefaultLifecycleExecutor.java:348)
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLi
> fecycleExecutor.java:180)
>         at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
>         at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
>         at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
>         at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:6
> 0)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
> java:39)
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
> sorImpl.java:25)
>         at java.lang.reflect.Method.invoke(Method.java:597)
>         at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>         at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>         at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
> 
>         at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
> Caused by: org.apache.maven.plugin.MojoExecutionException: Error uploading site
>         at org.apache.maven.plugins.site.SiteDeployMojo.execute(SiteDeployMojo.j
> ava:215)
>         at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPlugi
> nManager.java:490)
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(Defa
> ultLifecycleExecutor.java:694)
>         ... 17 more
> Caused by: org.apache.maven.wagon.authentication.AuthenticationException: Cannot
>  connect. Reason: Auth fail
>         at org.apache.maven.wagon.providers.ssh.jsch.AbstractJschWagon.openConne
> ctionInternal(AbstractJschWagon.java:264)
>         at org.apache.maven.wagon.AbstractWagon.openConnection(AbstractWagon.jav
> a:105)
>         at org.apache.maven.wagon.AbstractWagon.connect(AbstractWagon.java:207)
>         at org.apache.maven.wagon.AbstractWagon.connect(AbstractWagon.java:142)
>         at org.apache.maven.plugins.site.SiteDeployMojo.execute(SiteDeployMojo.j
> ava:184)
>         ... 19 more
> Caused by: com.jcraft.jsch.JSchException: Auth fail
>         at com.jcraft.jsch.Session.connect(Session.java:451)
>         at com.jcraft.jsch.Session.connect(Session.java:149)
>         at org.apache.maven.wagon.providers.ssh.jsch.AbstractJschWagon.openConne
> ctionInternal(AbstractJschWagon.java:236)
>         ... 23 more
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 43 seconds
> [INFO] Finished at: Mon Apr 05 21:59:46 PDT 2010
> [INFO] Final Memory: 13M/31M
> [INFO] ------------------------------------------------------------------------
> 
> 
> 
>       
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message