commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: [all] commons-parent-13 problems
Date Wed, 10 Mar 2010 23:34:43 GMT
On 10/03/2010, Niall Pemberton <niall.pemberton@gmail.com> wrote:
> On Tue, Mar 9, 2010 at 1:18 PM, Jörg Schaible <joerg.schaible@gmx.de> wrote:
>  > Hi Niall,
>  >
>  > Niall Pemberton wrote at Dienstag, 9. März 2010 02:42:
>  >
>  >> Unfortunately the upgrade of the maven-site-plugin from 2.0.1 to 2.1
>  >> has caused the site generation for Chain, Configuration and DBCP to
>  >> now fail. I'm looking into this to see whether its something we can
>  >> fix in the components or whether we need to downgrade the site plugin
>  >> version.
>  >>
>  >> I have reverted the maven-bundle-plugin version to 1.4.3 and the
>  >> maven-remote-resources-plugin to 1.0 (version 1.1 inherited from
>  >> apache parent 7) - this restores JDK 1.4 compatibility for "mvn
>  >> package/install".
>  >
>  > Did you give the animal-sniffer a try?
>
>
> No, but this is more Sebb's thing. I think its still a good idea to
>  build/test on the target JDK when checking out a release. Which is
>  what I did for Lang 2.5 and Beanutiles 1.8.x

I am working on a fix for the parent pom which allows the compile &
test to be run under a different JVM than Maven itself.

The proposed fix is to add profiles for Java 1.3 and Java 1.4 (even
Java 1.5); these profiles are used to tweak the compiler and surefire
plugin configurations.

By default the build would use the same JVM as Maven - i.e. same as at
present - but if the user has installed other versions of the JVM,
they can define the JVM locations (e.g. in settings.xml) and enable
the appropriate JVM using the relevant profile.

I think this should address all the requirements we have.

>
>  Niall
>
>
>  >>
>  >> http://svn.apache.org/viewvc?view=revision&revision=920607
>  >>
>  >> maven-site-plugin 2.1 requires maven 2.1 to run (which AFAIK needs JDK
>  >> 1.5) - so currently the site won't generate using JDK 1.4 - reverting
>  >> to 2.0.1 of the site plugin is required to run under JDK 1.4 - do we
>  >> need that?
>  >>
>  >> Also I noticed in the apache parent the following comment for the
>  >> maven-javadoc-plugin:
>  >>    "NOTE: 2.6.x is generally unusuable due to MJAVADOC-275"
>  >>     http://jira.codehaus.org/browse/MJAVADOC-275
>  >>
>  >> So probably we should revert to 2.5 for the javadoc plugin
>  >
>  > You have to here :-/
>  >
>  > - Jörg
>  >
>  >
>  > ---------------------------------------------------------------------
>  > To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>  > For additional commands, e-mail: dev-help@commons.apache.org
>  >
>  >
>
>  ---------------------------------------------------------------------
>  To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>  For additional commands, e-mail: dev-help@commons.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message