commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torsten Curdt <>
Subject Re: svn commit: r911797 - /commons/proper/compress/trunk/src/changes/changes.xml
Date Fri, 19 Feb 2010 17:49:51 GMT
>> While I am fine with the changes itself I find the naming "canRead" on
>> an InputStream a little ambiguous.
>> Maybe "canReadArchiveEntry"? Open to other suggestions.
> I'm not attached to names and can live with either.  I don't feel
> stream.canRead(anEntry) is ambiguos, but then again I know what it does.

stream.canWrite(entry) is clear

stream.canRead(entry) I am not quite sure what to make of

I am using getNextEntry() to get an entry.
So I was actually able to read the entry already, no?

What I was referring to in the first place was canRead vs available though.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message