commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <>
Subject Re: [DBCP] Continuum Java 5 build - please?
Date Tue, 05 Jan 2010 11:20:55 GMT
sebb wrote:
> It would be very useful to have a Continuum DBCP build that used Java 5.
> The current build uses Java 6 only, so does not test JDBC3 compatibility.
> I don't have Commons Admin on Continuum (and I'm not very familiar
> with it) so please could an Admin add it?
> Thanks!
I will look at this tonight.  It will have to be done using Ant and
maybe a little scripting, which I am not sure continuum will support.

The Ant build in trunk will filter sources in the /build directory
(not changing src/ itself) when it runs under <= 1.5, but it
requires to be set.

The Maven build under <=1.5 requires that the sources be
pre-filtered in the src/ directory.

I use the Ant build in trunk to test compatibility manually.

> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message