commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver Heger <oliver.he...@oliver-heger.de>
Subject Re: [configuration] Dependencies after switch to 1.4
Date Sun, 03 Jan 2010 13:07:53 GMT
Ralph Goers schrieb:
> I believe this could be addressed by changing the pom to only include Xerces and XML-APIs
when compiling with JDK 5+ with a desired target of JDK 5+ and then having the unit tests
that use validation only run when Java 5+ is enabled. However, this seems like a lot of work
for little benefit since Xerces and XML-APIs already have test scope so they won't be brought
in to a user's project unless they wants them. 
> 
> Ralph

Agreed, it is probably not worth the effort. So it is a matter of 
documentation on our dependencies page. There has to be a statement that 
Xerces is required on JDK 1.4 for schema validation.

Oliver

> 
> 
> On Jan 2, 2010, at 12:22 PM, Oliver Heger wrote:
> 
>> In order to change the minimum required JDK to 1.4 I modified pom.xml. I was hoping
to get rid of all the XML-related dependencies, but obviously this is not so easy.
>>
>> When dropping the Xerces-dependency I get a bunch of test failures:
>> - Many of them are caused by tests for DatabaseConfiguration. Here dbunit cannot
resolve the DTD in the dataset file. This can be solved by simply removing the reference to
the DTD.
>> - The major problem is caused by tests that require advanced validation features,
e.g. schema validation. This is not supported by the parser shipped with Java 1.4.
>>
>> Because of the latter point I think we are forced to keep the Xerces-dependency (with
test scope). Unfortunately, this also demands the dependency to XML-APIs - otherwise I get
NoClassDefFound errors.
>>
>> Or is there an alternative?
>>
>> At least the dependency to Xalan can be dropped. I wonder whether this has some impact
on GUMP which has still trouble with building [configuration].
>>
>> Oliver
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>> For additional commands, e-mail: dev-help@commons.apache.org
>>
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message