commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Niall Pemberton <niall.pember...@gmail.com>
Subject Re: Using maven 2 on non-MSFT platform to build JEXL
Date Tue, 08 Dec 2009 17:19:23 GMT
On Tue, Dec 8, 2009 at 4:55 PM, henrib <henrib@apache.org> wrote:
>
> I've been fighting with the JEXL environment (on a Mac) to get it to generate
> an 'mvn site' correctly; in particular, the reports are not included and the
> css are wrong.
>
> I duplicated the same env on the Mac and on a Windows box, clean from maven
> to checkout, commons-build checked out as peer, and... the Windows version
> does generate the site correctly whilst the Mac version has the previous
> problems!
>
> It may or may not be related to MSITE-404 but in any case, it means Mac is
> unusable to publish a release candidate or a build. If anyone successfully
> using a non-Windows platform could just perform a double check (svn co jexl,
> mvn site: no reports accessible from the left hand side mean failure), I'd
> really appreciate it.
>
> It might allow us to warn Un*x-ians of our community not to waste hours
> trying to build on their platform.
>
> If someone has *any* solution - besides virtualbox-ing Windows XP -, I'll
> gladly give it a try.

Does it make any difference if you remove the leading slash from the
href="/...html" attribute on the <item> elements in site.xml?

http://svn.apache.org/repos/asf/commons/proper/jexl/trunk/src/site/site.xml

Niall

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message