commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <phil.ste...@gmail.com>
Subject Re: [VOTE] Release DBCP 1.3/1.4 - take three
Date Wed, 30 Dec 2009 16:02:18 GMT
sebb wrote:
> On 29/12/2009, Phil Steitz <phil.steitz@gmail.com> wrote:
>> Hopefully all problems with JDK versions and the site build have now
>>  been resolved.  As previously discussed, the only difference between
>>  1.3 and 1.4 is that the 1.3 sources have been filtered to exclude
>>  JDBC4 methods.  Version 1.3 is for JDK 1.4-1.5 and only builds under
>>  one of these JDKs.  Note that to execute the 1.3 maven build under
>>  JDK 1.4 you need a 2.0.x version of maven.
>>
>>  Here are the artifacts:
>>
>>  1.3 (JDBC 3) version:
>>  http://people.apache.org/~psteitz/dbcp-1.3-rc6
>>  http://people.apache.org/~psteitz/dbcp-1.3-rc6/site
>>  http://people.apache.org/~psteitz/dbcp-1.3-rc6/maven
>>  http://svn.apache.org/repos/asf/commons/proper/dbcp/tags/DBCP_1_3_RC6/
>>
>>  1.4 (JDBC 4) version:
>>  http://people.apache.org/~psteitz/dbcp-1.4-rc6
>>  http://people.apache.org/~psteitz/dbcp-1.4-rc6/site
>>  http://people.apache.org/~psteitz/dbcp-1.4-rc6/maven
>>  http://svn.apache.org/repos/asf/commons/proper/dbcp/tags/DBCP_1_4_RC6/
> 
> Sigs, hashes OK.
> Source archives agree with SVN Tag, apart from doap,
> release-process.txt and build-1.3.xml. I think these are OK.

You mean these are in the tag, but not in the source distro.  This
is by design.

> 
> It would be nice if the source manifest included Java source version,
> but not essential.
> 
> The source and binary archives both contain the file
> 
> testpool.jocl
> 
> which comes from the src/test directory in SVN.

This file should not be in the binary distro.  I don't see it in
either the 1.3 or 1.4 tars.  Where are you finding it in the binary
distro?  It needs to be in the source distro as it is required by
the unit tests.

> 
> As a test file, surely it should not be there?
> 
> Not a blocker, but should be fixed for any future release.
> 
> The 1.3 code builds and tests OK with Java 1.4.2 and 1.5.0, but
> generates a lot of stack traces from TestManual.testLogWriter().
> Ideally the output should be suppressed.

Agree there.  Any ideas on how to achieve what the test is trying to
do while suppressing console output in a platform independent way
would be appreciated.  Not a showstopper for release, however.

> 
> However, compilation fails when using Java 1.6.0. Unfortunately the POM says:
> 
> <!-- Target Java versions are actually 1.4, 1.5 and 1.6 -->

This should be dropped from the maven POM, since the maven build
does not do the conditional compilation.

> 
> Also README says:
> 
> This release of JDBC compiles with and supports JDK 1.4-1.5 (JDBC 3.0)
> and JDK 1.6 (JDBC 4.0).  The 1.4 binary release requires JDK 1.6 (JDBC 4.0).
> The 1.3 binary release was built from filtered versions of the same sources
> using JDK 1.5.0_19.
> <<<
> 
> The compilation errors seem to be all instances of concrete classes
> failing to override abstract methods.
> 
> It may be possible to fix it so that the code will compile OK with
> Java 1.6.0, but if not, the descriptions should be updated, as this is
> unusual and unexpected behaviour (AFAIK, all other commons components
> are upwards compatible).

See Niall's comments.

> 
> I think this warrants a -1.

I am on the fence here.  I definitely want to limit confusion for
users, which I obviously have not done since commons committers did
not understand the intent of the statements in the release notes,
readme and changes reports.

I am personally OK with moving forward with the release and adding
prominent statements describing compatibility state in both the
release announcement and on the updated web site post-release.

I respect your opinion, however, and will proceed with another RC if
you feel it is warranted.

Phil


> 
> Sorry I was not able to test earlier release candidates.
> 
>>  Release notes (common version, ships with both)
>>  http://people.apache.org/~psteitz/RELEASE-NOTES.txt
>>
>>  Votes, please. This VOTE will close 01-January-2010 03:30 GMT.
>>
>>  [ ] +1 Proceed with release
>>  [ ] +0 OK
>>  [ ] -0 OK, but I would prefer...
>>  [ ] -1 No, showstopper = ...
>>
>>  Thanks!
>>
>>  Phil
>>
>>  ---------------------------------------------------------------------
>>  To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>  For additional commands, e-mail: dev-help@commons.apache.org
>>
>>
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message