commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <joerg.schai...@gmx.de>
Subject [vfs] JDK 1.5
Date Mon, 09 Nov 2009 06:24:22 GMT
Guys,

looking at Ralph's comment in https://issues.apache.org/jira/browse/VFS-254
I am questionning myself, if there's any reason why vfs 2.0 should still
have JDK 1.4 as requirement and not JDK 1.5. VFS 2.0 will be a major
release and JDK 1.7 is years away to be used for our conservative
customers. Although we have still some maintenance support for JDK
1.4-based apps, they're phasing out and we will definitely not update
dependencies with major releases. Therefore I'd rather have a VFS with more
modern API (generics) in 2.0 than an "old-fashioned" version 2.0 based on
JDK 1.4 especially if the major release means that API changes too much for
a drop in replacement of 1.1. Thoughts ?

- Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message