commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mario Ivankovits <ma...@ops.co.at>
Subject RE: [vfs] JDK 1.5
Date Mon, 09 Nov 2009 06:43:31 GMT

Hi!
 
> looking at Ralph's comment in
> https://issues.apache.org/jira/browse/VFS-254
> I am questionning myself, if there's any reason why vfs 2.0 should
> still
> have JDK 1.4 as requirement and not JDK 1.5.

If it is just me, I'd be happy to drop 1.4 dependency - Past votes were declined. Probably
the time is ripe now.

If it is worth to generify the API is another story - as Ralph pointed out, the next logical
step for VFS is to support the upcomming JDK 1.7 file.spi stuff. That is also my view, and
hopefully falls into times where I have more time left to spend for VFS again.
Having a complete new api I see no point putting efforts into generifying the current api.
If we discover that the JDK 1.7 api is too limiting thigs might change, though.

On the other hand, as the VFS api is today, generifying it might be a "no-brainer" ;-)
We event might manage to generify without changed the VFS api - keeping it backward compatible.


Ciao,
Mario
Mime
View raw message