commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Benedict <>
Subject Re: [lang 3] Validate: rename methods
Date Mon, 30 Nov 2009 07:36:26 GMT
It is a verb, of course, but methods should be verbs. I am only 
appealing to the classical naming convention of methods. They do the 
work; classes don't. You can't ask a class to validate; you can ask its 
methods to validate.


On 11/30/2009 1:31 AM, Henri Yandell wrote:
> Validate isn't a verb?
> On Sun, Nov 29, 2009 at 9:06 PM, Paul Benedict<>  wrote:
>> I am not catering to static imports. I am catering towards a
>> consistent naming convention. If you compare our names to what exists
>> in Spring's and Google's API, you will find that ours are not
>> verb-ified. The whole static import discussion is just an additional
>> benefit.
>> What I would like to focus on is having a common verb in front of all.
>> Saying "notNull" is a statement, not an action. Is that really what we
>> want to keep?
>> Paul

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message