commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <joerg.schai...@gmx.de>
Subject Re: [VOTE] Release commons-parent 12
Date Sat, 17 Oct 2009 19:22:24 GMT
Niall Pemberton wrote:

> On Sat, Oct 17, 2009 at 12:47 PM, Jörg Schaible <joerg.schaible@gmx.de>
> wrote:
>> Hi Nial,
>>
>> Niall Pemberton wrote:
>>
>>> Hi,
>>>
>>> I'd like to release version 12 of the commons-parent pom - the changes
>>> since the last release are:
>>>
>>> - the javadoc jar now has standard entries (e.g. version, title)
>>> added to its MANIFEST.MF file
>>> - the sources jar now has standard entries (e.g. version, title)
>>> added to its MANIFEST.MF file
>>> - project.build.sourceEncoding added and set to iso-8859-1
>>> - project.reporting.outputEncoding added and set to iso-8859-1
>>> - inceptionYear removed
>>> - Update plugin versions to the latest release
>>
>> ======== %< ===========
>> $ mvn versions:display-plugin-updates
>> ...
>> [INFO] The following plugin updates are available:
>> [INFO]   org.apache.felix:maven-bundle-plugin ................. 1.4.0 ->
>> 2.0.1
>> ======== %< ===========
>>
>> Is there a reason, why we do not use the latest version of the bundle
>> plugin?
> 
> 2.x requires JDK 1.5 also I vaguely remember some problem that would
> have caused a problem for us - that was probably 2.0 rather than 2.0.1
> - but I never got time to investigate. I'm OK with minimum of JDK 1.5
> (I'm running maven 2.2.1 which requires that) - but wasn't sure, so
> thought I would leave that plugin for the moment.

Ah. Right. I remember now. Maybe simply add a little comment to the POM, why
we stick to 1.x for the next time.

>>> - idea plugin locked down in pluginManagement
>>
>> Why? Plugins like idea, eclipse or netbeans should not be locked down.
>> Even if you checkout an old version of a project from a tag, you will
>> still use your latest IntelliJ IDEA version, therefore the idea plugin
>> should generate projects matching that one and not an ancient release.
> 
> OK I don't actually use it - I was playing with maven 3 which now
> warns when you don't lock down plugin versions and its usually a *good
> practice*. 

In general - yes.

> But you make a good argument so I'll revert that. 
> 
>> Thoughts?
>>
>>> - plugin list now sorted
>>> - sanselan & compress added to modules
>>
>> ======== %< ===========
>> [WARNING] The following plugins do not have their version specified:
>> [WARNING]   maven-clean-plugin .......................... (from
>> [super-pom)
>> 2.1
>> [WARNING]   maven-deploy-plugin ....................... (from super-pom)
>> 2.2.1
>> ======== %< ===========
>>
>> IMHO these should be locked down also (with their latest version). Now it
>> depends on the Maven version in use.
> 
> Good catch I'll add those as well.

Thanks,
Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message