commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Niall Pemberton <niall.pember...@gmail.com>
Subject Re: Problems releasing commons-parent 12
Date Tue, 20 Oct 2009 21:21:07 GMT
On Tue, Oct 20, 2009 at 8:04 PM, Dennis Lundberg <dennisl@apache.org> wrote:
> Run the exact same command once more.
> This has been known to happen from time to time.

I've tried it four times and it has failed with the same problem each
time. One of the changes in this release was to upgrade the
maven-release-plugin from version 2.0-beta-7 to 2.0-beta-9. Perhaps I
should try reverting that changes and see if that fixes it. Can't
think of anything else to try, unless someone else wants to have a go
and see if it works for them.

Niall

> Niall Pemberton wrote:
>> I'm having problems doing the release of commons-parent 12
>>
>> Running the following command:
>>
>>   mvn -Prelease release:prepare -Dusername=niallp -Dpassword=*******
>>
>> ...works partially. It updates the pom.xml (version & scm tags) and
>> commits the changes but then fails when it tries to tag with the
>> following output:
>>
>> -----------------------------------------
>> [INFO] Unable to tag SCM
>> Provider message:
>> The svn tag command failed.
>> Command output:
>> svn: No such revision 827754
>> -----------------------------------------
>>
>>
>> The revision number indicated was the one from the commit of the
>> previous pom changes.
>>
>> Any ideas anyone?
>>
>> Niall

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message