commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Lundberg <denn...@apache.org>
Subject Re: Problems releasing commons-parent 12
Date Thu, 22 Oct 2009 20:13:50 GMT
Siegfried Goeschl wrote:
> Hi Niall,
> 
> basically I had all problems you mentioned
> 
> +) SVN 1.5 works and all newer version seems to be broken with M2 (SVN
> 1.5.4 and 1.6 did not work)

For full details on this issue see
http://jira.codehaus.org/browse/SCM-406

> +) Maven 2.2.1 worked but not 2.0.9 & 2.0.10
> +) some SVN problems stem from the fact you are committing on Europe SVN
> server

This is most likely what happened to Niall.

> 
> Siegfried Goeschl
> 
> Dennis Lundberg wrote:
>> Niall Pemberton wrote:
>>   
>>> On Tue, Oct 20, 2009 at 10:36 PM, James Carman
>>> <james@carmanconsulting.com> wrote:
>>>     
>>>> I did not rollback the commit.
>>>>       
>>> OK that worked for the release:prepare command - now I'm stuck on
>>> release:perform - it gets to the deploy:deploy stage and I get the
>>> following message:
>>>
>>> [INFO] The authenticity of host 'people.apache.org' can't be established.
>>> [INFO] DSA key fingerprint is 79:7c:cb:6a:44:47:b2:ef:5c:66:28:d7:40:0d:b1:f9
>>>
>>> Then it just hangs - any ideas?
>>>     
>> I think there was a change made on the repository side of this, that
>> requires a fix for Maven (the application). It has been fixed, but I
>> can't remember in which version. You can try using Maven 2.2.1 to see if
>> it solves the problem.
>>
>>   
>>> Niall
>>>
>>>     
>>>> On Tue, Oct 20, 2009 at 5:34 PM, Niall Pemberton
>>>> <niall.pemberton@gmail.com> wrote:
>>>>       
>>>>> On Tue, Oct 20, 2009 at 10:25 PM, James Carman
>>>>> <james@carmanconsulting.com> wrote:
>>>>>         
>>>>>> On Tue, Oct 20, 2009 at 5:21 PM, Niall Pemberton
>>>>>> <niall.pemberton@gmail.com> wrote:
>>>>>>           
>>>>>>> I've tried it four times and it has failed with the same problem
each
>>>>>>> time. One of the changes in this release was to upgrade the
>>>>>>> maven-release-plugin from version 2.0-beta-7 to 2.0-beta-9. Perhaps
I
>>>>>>> should try reverting that changes and see if that fixes it. Can't
>>>>>>> think of anything else to try, unless someone else wants to have
a go
>>>>>>> and see if it works for them.
>>>>>>>             
>>>>>> I've had trouble with the release plugin lately, too.  What I did
to
>>>>>> fix my problem was try the release, get the failure because of SVN
>>>>>> issues, then do svn update, then retry the release.
>>>>>>           
>>>>> Did you rollback the commit - or is it smart enough to carry on from
>>>>> where it failed?
>>>>>
>>>>> Niall
>>>>>         
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>
>>>
>>>     
>>
>>   
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
> 
> 


-- 
Dennis Lundberg

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message