commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Déflache <guillaume.defla...@wyona.com>
Subject Re: [JELLY] Branch to prepare for JEXL-2.0 enhancements?
Date Wed, 14 Oct 2009 15:50:49 GMT
Hi all!

Would you guys consider doing a 1.0.2 release any time soon too?

Paul Libbrecht a écrit :
> Some people might even say the whole of Jelly is dormant, and indeed, I, 

Indeed, before seeing this thread I was about to send a "is-Jelly-dead?" 
probe message instead of this! ;)


> as many other jelly committers have been unable to find cycles to simply 
> fix the most elementary things such as the wrong "how-to-start".

One thing that we would very much like to be in the next point release 
would be the fixes in <https://issues.apache.org/jira/browse/JELLY-286> 
that have already been tested and committed in Jelly-core's trunk, but 
never released.
E.g. the "Allow Expressions to throw exceptions" and " Jelly should 
throw an exception if an unknown tag is used in a TagLibrary" 
improvements (resp. <http://issues.apache.org/jira/browse/JELLY-163> and 
<http://issues.apache.org/jira/browse/JELLY-13>) would also be helpful 
to anyone developing with Jelly IMHO.

Also if going the Java >= 1.5 route you might consider fixing the 
apparently trivial "nested exceptions are displayed incorrectly with 
JellyException" bug (<http://issues.apache.org/jira/browse/JELLY-235>).

[...]
> Jelly is used here and there in not so visible projects... that's my 
> blurred estimate. Since jelly is glue oriented, it is typically not so 
> visible and could often be replaced by another glue, e.g. groovy, 
> beanshell, shell-scripting with some greps and xslt... therefore an 
> estimate is real hard to make.

For us because of these bugs and some other ones it's becoming more of a 
legacy library (we may try to move on to StringTemplate or even retreat 
to XSLT again), hence the dire need to get at least a more 
maintainer-friendly behaviour.


FYI we only need Java 1.5+ compatibility and reducing dependencies is 
always welcome! :)


Regards,
    Guillaume

P.S.: I initially wrote some blurb about this in 
<http://issues.apache.org/jira/browse/JELLY-163?focusedCommentId=12751827&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#action_12751827>

then in 
<http://mail-archives.apache.org/mod_mbox/commons-user/200908.mbox/%3C4A9699D7.6080702@wyona.com%3E>

without answer: I guess I should have come here in the 1st place, else 
please so tell me/point me to what is deemed appropriate for Commons.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message