commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rahul Akolkar <rahul.akol...@gmail.com>
Subject Re: [CONTINUUM] Add JEXL? Java version?
Date Thu, 20 Aug 2009 23:52:23 GMT
On Thu, Aug 20, 2009 at 7:46 AM, sebb<sebbaz@gmail.com> wrote:
> Not sure who is looking after Continuum for Commons, but it might be
> useful to add Jexl 2.0 to the list.
>
<snip/>

Yes (and its time to move the 2.0 branch to trunk now, with 1.x being
a branch, IMO).

I don't remember fiddling with continuum for Commons myself, so I
probably don't have the right karma on the vmbuild instance either.

-Rahul


> Also, the builds all seem to use Java 1.6, however no Commons
> components actually require Java 1.6 yet.
>
> Java 1.6 allows certain constructs which cause errors in Java 1.5, so
> defaulting to 1.6 means that some coding errors are not caught.
>
> Seems to me that it would be more useful (or at least as useful) to
> build each component with its target Java version (though one would
> have to use a minimum of Java 1.4).
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message