commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: [JEXL] 2.0 and BSF / JSR-223
Date Wed, 29 Jul 2009 18:25:41 GMT
On 29/07/2009, Henrib <hbiestro@gmail.com> wrote:
>
>  Could we envision this JSR-233 as a second & optional jar.

No; the whole point is that the classes need to be in the same jar.

>  Many of us are still stuck with Java5 and having to add the javax.api as a
>  dependency to Jexl could be inconvenient.
>  May be we can expose what is necessary from Jexl for the jsr-233 to be
>  efficiently implemented but still leave it as an option ?
>  Cheers

I'm proposing to use BSF 3.0 API which defines the JSR-223 APIs but
runs on Java 1.4+ as a compile-time only dependency.

I've already got the code compiling.

Of course if you try to use the new classes on Java 1.5  without also
providing BSF 3.0 the JVM will complain, but otherwise the Jexl jar
will run fine on Java 1.5.

> --
>  View this message in context: http://www.nabble.com/-JEXL--2.0-and-BSF---JSR-223-tp24706519p24724270.html
>  Sent from the Commons - Dev mailing list archive at Nabble.com.
>
>
>
>  ---------------------------------------------------------------------
>  To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>  For additional commands, e-mail: dev-help@commons.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message