commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rahul Akolkar <rahul.akol...@gmail.com>
Subject Re: commons-build site
Date Fri, 01 May 2009 20:57:00 GMT
On Thu, Apr 30, 2009 at 1:30 AM, Dan Fabulich <dan@fabulich.com> wrote:
>
> Well, there's no pom.xml in there that I can see.  Maven 1.0.2 reports a
> similar error:
>
<snip/>

>From memory, its m1.0.2 (which you have), maven-xdoc-plugin 1.9.2
(which you also have) and JDK 1.4 or 1.5 (but not 1.6, ISTR failures
with 1.6). If you figure out what the qdox error is below, drop a line
here for the archives.

-Rahul


> xdoc:init:
>    [echo] Generates the directory structure required for xdocs
> Attempting to download qdox-current.jar.
> WARNING: Failed to download qdox-current.jar.
>
> BUILD FAILED
> File...... C:\Documents and
> Settings\dan.fabulich\.maven\cache\maven-xdoc-plugin-1.9.2\plugin.jelly
> Element... attainGoal
> Line...... 1006
> Column.... 58
> The build cannot continue because of the following unsatisfied dependency:
>
> qdox-current.jar
>
> Total time: 3 seconds
> Finished at: Wed Apr 29 22:30:04 PDT 2009
>
> Henri Yandell wrote:
>
>> Hang on.... I'm pretty sure the site is Maven2 based :)
>>
>> On Wed, Apr 29, 2009 at 10:10 PM, Henri Yandell <flamefew@gmail.com>
>> wrote:
>>>
>>> Go with Maven 1.0.2.
>>>
>>> I seem to recall 1.1 not being too great.
>>>
>>> On Wed, Apr 29, 2009 at 10:02 PM, Dan Fabulich <dan@fabulich.com> wrote:
>>>>
>>>> I've never used m1 before, and am attempting to follow Rahul's
>>>> directions to
>>>> deploy the commons-build site to fix the downlead page for dbutils.
>>>>
>>>> I downloaded maven-1.1 and tried running "maven site:deploy".  It
>>>> downloaded
>>>> a bunch of stuff but then failed with the error below.
>>>>
>>>> Any idea what might be happening to me?
>>>>
>>>> Trying to get missing dependencies (and updated snapshots) required by
>>>> Maven
>>>> Tasklist Plug-in:
>>>> - Attempting to download vdoclet:vdoclet:20020711:jar from
>>>> http://repo1.maven.org/maven
>>>> 76K downloaded
>>>> - Attempting to download vdoclet:qdox:current:jar from
>>>> http://repo1.maven.org/maven
>>>>
>>>> -------------------------------------------------------------------------------
>>>>>>
>>>>>> Unable to obtain goal [site:deploy]
>>>>>> The build cannot continue because of the following unsatisfied
>>>>>> dependency:
>>>>
>>>> - vdoclet:qdox:current:jar
>>>>
>>>>
>>>> -------------------------------------------------------------------------------
>>>> BUILD FAILED
>>>>
>>>> -------------------------------------------------------------------------------
>>>> Total time   : 1 minutes 4 seconds
>>>> Finished at  : Wednesday, April 29, 2009 9:54:56 PM PDT
>>>> Final Memory : 5M/10M
>>>>
>>>> -------------------------------------------------------------------------------
>>>>
>>>> Rahul Akolkar wrote:
>>>>
>>>>> On Tue, Apr 28, 2009 at 2:47 PM, Dan Fabulich <dan@fabulich.com>
wrote:
>>>>>>
>>>>>> I'm so close to releasing DbUtils 1.2 I can taste it!
>>>>>>
>>>>>> http://commons.apache.org/downloads/download_dbutils.cgi
>>>>>>
>>>>>> This page only shows the 1.1 release, even though 1.2 is available
in
>>>>>> archives and on the mirrors.
>>>>>>
>>>>>> http://archive.apache.org/dist/commons/dbutils/binaries/
>>>>>>
>>>>>> What has to happen to fix the dbutils.cgi page?
>>>>>>
>>>>> <snip/>
>>>>>
>>>>> Update this:
>>>>>
>>>>>
>>>>>
>>>>>  http://svn.apache.org/repos/asf/commons/proper/commons-build/trunk/downloads/downloads.xml
>>>>>
>>>>> Then m1 build and deploy main Commons site (commons-build).
>>>>>
>>>>> -Rahul
>>>>>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message