commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Liam Coughlin <lscough...@gmail.com>
Subject Re: [dbutils] Version number for next release
Date Fri, 01 May 2009 17:33:54 GMT
You're right on the money with that one.

I'd like to have some brainstorming conversations and what not along the the
way to 2.0 -- I don't think a major version bump is necessary in a library
like this until you do break compatibility.

Cheers,
-L

On Fri, May 1, 2009 at 11:43 AM, Dan Fabulich <dan@fabulich.com> wrote:

>
> With the release of DbUtils 1.2, we're actually basically already ready to
> do another release of DbUtils, this time with enhancements specific to Java
> 5 (generics + varargs).
>
> The new Java 5 API is 100% compatible at runtime with the API of DbUtils
> 1.2 (or, at least, I tried to do so, I'll be sure to use API comparison
> tools prior to release and fix any bugs I find).
>
> I'd like to call this new release DbUtils 1.3.  I can imagine someone
> arguing that it should be 2.0, but I don't think so; in DbUtils 1.2 we just
> raised the required JRE version from 1.3 to 1.4 and I think that's fine.
>
> The difference between Java 1.4 and 1.5 is much bigger than the difference
> between 1.3 and 1.4, but not so great, I think, that a major version bump is
> required.
>
> If nobody objects, I'll start preparing for a DbUtils 1.3 release in about
> 72 hours.
>
> -Dan
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message