commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sam Halliday <>
Subject Re: [math] Re: commons-math, matrix-toolkits-java and consolidation
Date Thu, 21 May 2009 15:42:45 GMT

Regarding the name of ArrayRealMatrix. Please don't forget to include the
"2DRow" part to the name (indicating a 2D array which is Row ordered) to
indicate the implementation type. Post 2.0 I'll convince you that a 1D Array
approach is best as it will lead to more efficient use of BLAS and therefore
reproducibility of reference algorithms from, e.g. the Templates project on
netlib ;-)

I've never seen a storage type like BlockRealMatrix before... I'm interested
in seeing where it performs better than, say, a full 1D representation of a
dense matrix. Breaking up the storage like this makes it very difficult to
use BLAS/LAPACK internally.

Luc Maisonobe wrote:
>> - I discourage the use of the classes named *Impl. They will get very
>> confusing when other implementations are added later! Instead, I
>> recommend
>> the names ArrayRealVector, Array2DRowRealMatrix (to indicate a 2D array
>> backed implementation using row ordering). This allows a column-based or
>> 1D
>> implementation in the future without names getting very confusing. These
>> implementations are hidden from users who just use the MatrixUtils help
> Phil suggested to change RealMatrixImpl to ArrayRealMatrix (and
> DenseRealMatrix to BlockRealMatrix). This sounds good to me.

View this message in context:
Sent from the Commons - Dev mailing list archive at

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message