commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Meikle <loo...@gmail.com>
Subject Re: [resources] Supported Build Tools
Date Sun, 17 May 2009 21:40:34 GMT
Hi,

2009/5/17 Dave Meikle <loompa@gmail.com>

> 2009/5/17 Robert Burrell Donkin <robertburrelldonkin@blueyonder.co.uk>
>
>>  i'd prefer just to maintain a maven 2 if we're looking just to maintain
>> a JDK1.5+ version.
>>
>> jdk1.4 is now EOL'd and i don't have any particular need to support 1.4
>> but i'm happy to target 1.4 if there's a need.
>>
>
> +1 from me -  that is what I had done with my local copy. Although I have
> some Java 1.4 projects, targeting 1.5 sounds good to me as these will be
> moving up the way.
>
> We could do what we do in Tika and run the retrotranslator plugin in the
> Maven build to allow the classes to be used on 1.4.
>

OK, I have went for the above and removed the Ant builds. Coupled with
Robert's earlier change of removing the Maven 1 build, we are now just using
Maven 2.

I have set the Target to 1.5 and added in a retrotranslator just now.

Cheers,
Dave

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message