commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Barker" <billwbar...@verizon.net>
Subject Re: [math] Re: commons-math, matrix-toolkits-java and consolidation
Date Sat, 16 May 2009 22:51:39 GMT

----- Original Message ----- 
From: "Ted Dunning" <ted.dunning@gmail.com>
To: "Commons Developers List" <dev@commons.apache.org>
Sent: Saturday, May 16, 2009 1:01 PM
Subject: Re: [math] Re: commons-math, matrix-toolkits-java and consolidation


> +1 on this change.  Grand names like SparseRealMatrix should be reserved 
> for
> the interfaces.
>

I'm +1 on these grounds (and, yes, that means I'm volunteering to do the 
work).  I could add the getSparcity method as well (the only one that is 
useful for 2.0).  Could do the getShape which would presumably return an 
enum (which would only have one element in 2.0) to ease the pain of 
upgrading to 2.1 when there are more.



> On Sat, May 16, 2009 at 10:26 AM, Luc Maisonobe 
> <Luc.Maisonobe@free.fr>wrote:
>
>>
>> > - rename SparseReal{Matrix, Vector} to OpenMapRealSparse{Matrix, 
>> > Vector}.
>> > Implement above interfaces.
>>
>> I have no opinion on that. What do others think ?
>
>
>
>
> -- 
> Ted Dunning, CTO
> DeepDyve
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message