commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Barker" <wbar...@wilshire.com>
Subject [math] Java 6 dependancies
Date Wed, 22 Apr 2009 04:49:56 GMT
I can't compile commons-math any longer due to the below errors.  It seems 
that some 1.6 methods have creaped in.  I have no problem upgrading to 1.6 
if that is what is necessary, but I thought 1.5 was the targeted version.

    [javac] symbol  : method newInstance(java.lang.Class<capture of ? 
extends org.apache.commons.math.FieldElement>,int,int)
    [javac] location: class java.lang.reflect.Array
    [javac]             (T[][]) 
Array.newInstance(field.getZero().getClass(), rows, columns);
    [javac]                          ^
    [javac] symbol  : method newInstance(java.lang.Class<capture of ? 
extends org.apache.commons.math.FieldElement>,int,int)
    [javac] location: class java.lang.reflect.Array
    [javac]         final T[][] d = (T[][]) 
Array.newInstance(zero.getClass(), dimension, dimension);
    [javac]                                      ^ 




---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message