commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Grobmeier <grobme...@gmail.com>
Subject Re: [COMPRESS] TarUtils - rename of getxxx() methods; TarArchiveEntry StringBuffer=>String
Date Thu, 02 Apr 2009 15:02:47 GMT
I think all proposed changes are good.
Tar looks quite complex for my taste and everything which makes this
part of compress more easy is highly appreciated.

Cheers


On Thu, Apr 2, 2009 at 4:09 PM, sebb <sebbaz@gmail.com> wrote:
> I find it confusing to have get() as the inverse to parse() - usually
> there are parse() and format() methods.
>
> So I'd like to rename the TarUtils getXXX() methods to formatXXX()
> instead, as that is what the methods actually do - they format the
> input long or stringbuffer into a byte buffer.
>
> Any objections?
>
> Also, TarArchiveEntry mostly uses StringBuffer rather than String. As
> the variables are rarely updated - just written and read - this seems
> unnecessary (perhaps wasteful), and does not agree with the way the
> other ArchiveEntry classes are implemented.
>
> So I'd like to change these to String instead.
> This will change the API for TarUtils.
>
> Any objections?
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message